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Indicações básicas

Salvamento para web

Por padrão, tenha em mente:

Fotografias que não tenham transparência devem ser sempre sal-
vas em JPG;

Como padrão, as imagens em JPG devem ter sempre 70% de quali-
dade. Evitar qualidade maior;

Para ilustrações (chapadas, vetores) preferir sempre, nessa ordem, 
PNG8 e GIF, tentando sempre manter a paleta em até 64 cores;

Para ilustrações com transparência, que contenham bordas irre-
gulares, usar sempre PNG 24. Para fotos com transparência, usar 
sempre PNG24;

Para ilustrações com transparência, que contenham bordas (ou 
aberturas) retas, avaliar a possibilidade de usar PNG8 ANTES de 
usar PNG24;

No Photoshop, usar sempre a ferramenta “Save for web”

Observação
A Adobe implementou um novo box de salvamento e aconselha 
que seja utilizado. Trata-se do Export > Export as. Até o momento 
da finalização desse guia, a nova ferramenta apresentava bugs. Em 
uma rápida pesquisa nos fóruns da empresa, é possível atestar que 
em todas as novas versões do Photoshop CC a ferramenta apresen-
ta problemas. O ideal, portanto, é usar o box Save for web até que 
uma nova versão da suíte corrija os problemas encontrados.

Nomenclatura correta de imagens

Nunca utilizar acentuação nos nomes de arquivos (¨ ´ ` ^ ~);

Nunca utilizar caracteres especiais nos nomes de arquivo (@ # $ % 
& * ( ) { } [ ] ª º ? / \ | - +);

Nunca utilizar pontuação nos nomes de arquivos (, . ; :);

Nunca utilizar aspas simples ou duplas nos nomes de arquivos (“ ‘);

Sempre utilizar o hífen - como separador de palavras, nunca o un-
derscore (_) ou ponto (.);



5Pequeno manual de otimização de imagens para web · Danilo Pegorara · Design gráfico

TL; DR

JPEG · Fluxo 1 · compressão moderada
Fluxo padrão de otimização no Photoshop para imagens fotogáficas

Image > Image size
Alterar para 72 DPI / Alterar dimensões em pixel para o tamanho 
da exibição. Vale a pena testar os engines de reamostragem. Em 
imagens complexas, normalmente os efeitos com smoothing são 
melhores em reduzir o tamanho do que os que usam sharpening.

File > Export > Save for web
– JPEG
– Quality 70
– Progressive

JPEG · Fluxo 2 · maior compressão
Mesmo fluxo, adicionando software externo (File Optimizer)

JPEG

JPEG · Fluxo 3 · compressão máxima
Mesmo fluxo, porém, com um tempo maior de avaliação das confi-
gurações do Save for web. Algumas imagens mais detalhadas tole-
ram um nível baixo de qualidade sem perder muito da fidelidade.

– Baixar a qualidade do JPEG em gradações de 10 e observar o mo-
mento em que a imagem começar a apresentar distorções.

– Alterar a configuração de BLUR. Dependendo da imagem, é possí-
vel chegar a 0,25 sem perda visível de fidelidade.

– Utilizar software externo (File Optimizer)

Observações:
Softwares externos como o File Optimizer usam mais de uma ferra-
menta para comprimir os arquivos, essas ferramentas normalmente 
reduzem a profundidade de cor das imagens e removem todos os 
seus metadados. O ideal é usá-los somente na última etapa, depois 
de conferir se o arquivo está correto. Alterações devem ser feitas 
no original e o arquivo otimizado novamente.

JPEG comprime melhor imagens menos nítidas. Borrar o fundo, usar a 
ferramenta smudge para suavizar transições de cor ou converter para 
escala de cinza (quando desejável) reduzem o tamanho do arquivo.
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JPEG original
4928 x 3280 @ 300 DPI
13,2 MB

Image size > 72 DPI > 
Save as JPEG
1183 x 787 @ 72 DPI
1,22 MB 
Tempo @ 1mb/s: 13 segundos

Image size > 72 DPI > 
Export > Save for web > 
[JPEG·Quality 70·Progressive]
1183 x 787 @ 72 DPI
440 KB
Tempo @ 1mb/s: 5 segundos

Image size > 72 DPI > 
Export > Save for web > 
[JPEG·Quality 70·Progressive] 
> File Optimizer
1183 x 787 @ 72 DPI
431 KB
Tempo @ 1mb/s: 4.8 segundos

Image size > 72 DPI > 
Export > Save for web > 
[JPEG·Quality 40·Progressi-
ve·Blur:0,25] > File Optimizer
1183 x 787 @ 72 DPI
187 KB
Tempo @ 1mb/s: 2.1 segundos

Image size > 72 DPI > 
Export > Save for web > 
[JPEG·Quality 35·Progressi-
ve·Blur:0,3] > File Optimizer
1183 x 787 @ 72 DPI
163 KB
Tempo @ 1mb/s: 1.8 segundos

307KB

Imagem padrão

245KB

Gaussian blur
5.0 no fundo

ExemplosJPEG
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TL; DR

File > Export > Save for web
– PNG-24
– Ativar Transparency (dependendo do uso)
– Ativar Interlaced

PNG · Fluxo 2 · maior compressão
Mesmo fluxo, porém avaliando se o custo/benefício de ativar o in-
terlace é bom. Em arquivos com interlace ligado, o navegador ren-
deriza uma imagem de baixa qualidade enquanto carrega a imagem 
final, porém, o arquivo fica maior. Essa diferença de tamanho é que 
vai definir se o recurso deve ou não ser usado.

PNG · Fluxo 3 · compressão máxima
Dependendo da imagem, é possível salvá-la em PNG-8:

Método 1
– Baixar o número de cores até perceber distorções na imagem

Método 2
– Remover cores da paleta manualmente. Em alguns casos, um la-
ranja mais claro pode estar indexado para fazer a transição de um 
laranja mais escuro para branco por exemplo. Nesse caso, remover 
o laranja mais claro geralmente não altera a percepção de qualida-
de de imagem. É possível também, selecionar uma área com dois 
laranjas e pintá-la com somente um antes de salvar.

– Dither
Esse recurso introduz uma malha predeterminada de ruído na ima-
gem, para minimizar o efeito de color banding. O color banding é o 
efeito (indesejado) que transforma um degradê em faixas demar-
cadas de diferentes cores. Noise costuma ser a melhor opção, mas 
aumenta consideravelmente o tamanho do arquivo. Algum color 
banding em fundos ou elementos pequenos pode ser aceitável, de-
pendendo do uso da imagem.
– Usar software externo (File Optimizer)

PNG · Fluxo 1 · compressão moderada
Fluxo padrão de otimização no Photoshop / Illustrator para ima-
gens vetoriais ou com cores chapadas

Image > Image size (PS) / Effect > Document raster effects settings (AI)
Alterar para 72 DPI / Alterar dimensões em pixel para o tamanho da 
exibição. No caso do Illustrator, alterar raster effects para 72 DPI.

A otimização de PNG costuma ser lenta, mas costuma compensar.

Observações:
O uso de PNG24 transparente deve ser evitado ao máximo, pois só 
permite salvamento com canal alfa, o que aumenta consideravel-
mente o tamanho do arquivo. Hipoteticamente, se a cor de fundo da 
página é diferente da cor de fundo da imagem, o ideal é alterar o fun-
do da imagem para a mesma cor (em hexa). Excetuando-se, claro, as 
situações nas quais a imagem será usada em mais de um fundo. Se a 
imagem for quadrada, é possível salvar em PNG-8 com transparência.

Color banding Dither > pattern Dither > noise

PNG



Pequeno manual de otimização de imagens para web · Danilo Pegorara · Design gráfi co8

Exemplos

EPS original
805 x 548 @ 72 DPI
11.5 MB

PNG 24
805 x 548 @ 72 DPI
224 KB
Tempo @ 1mb/s: 3 segundos

Image size > 72 DPI >
Export > Save for web >
[PNG24·Interlaced]
805 x 547 @ 72 DPI
223,7 KB
Tempo @ 1mb/s: 3 segundos

Image size > 72 DPI >
Export > Save for web >
[PNG8·256·Selective·Pattern] 
> File Optimizer
805 x 547 @ 72 DPI
71,6 KB
Tempo @ 1mb/s: 1.8 segundos

Image size > 72 DPI >
Export > Save for web >
[PNG8·128·Selective·Noise] > 
File Optimizer
805 x 547 @ 72 DPI
59,5 KB
Tempo @ 1mb/s: 1.4 segundos

Save for web > [PNG24]
22,1 KB
Tempo @ 1mb/s: 0.2 segundos

Save for web > [PNG8·64] > 
File optimizer
6,46 KB
Tempo @ 1mb/s: 0.07 segundos

Transparência (cortes quadrados)

PNG
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GIF · Fluxo 1 · compressão moderada
File > Export > Save for web
– GIF
– 128
– Selective

GIF · Fluxo 2 · maior compressão
Mesmo fluxo, porém baixando a paleta de cores para 64 (se possível).
File > Export > Save for web
– GIF
– 64
– Selective

GIF · Fluxo 3 · Compressão máxima
File > Export > Save for web
– GIF
– Selective
– Habilitar o conta-gotas, selecionar as cores principais e travá-las 
com o botão de cadeado abaixo da paleta. Dessa forma, as cores 
principais não serão cortadas quando a paleta for reduzida.
– Reduzir a paleta para 32 cores e avaliar o nível de perda na imagem. 
– Usar software externo (File Optimizer)

Observações:
As observações sobre remoção de cores e dithering dos fluxos de 
PNG também se aplicam ao salvamento em GIF.

O formato GIF pode ser usado nas mesmas imagens que se qualificam 
para serem salvas em PNG (cores chapadas, não-fotográficas, com fun-
do transparente, etc), porém tenha em mente que na grande maioria 
dos casos, o formato PNG oferece o melhor custo benefício.

O único uso para o qual o formato deve ser considerado exclusiva-
mente é o de animação. As sugestões de salvamento apresentadas 
também funcionam para GIF animado, embora existam ainda outros 
meios de otimizar esse tipo de arquivo.

Nos exemplos, o uso do algoritmo “selective” é o que proporcio-
nou melhor custo x benefício nessa imagem específica. É impor-
tante testar os outros algoritmos disponíveis e avaliar seus dife-
rentes efeitos na imagem, e o custo benefício de cada um.

GIFTL; DR
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Exemplos · Observe a diferença entre os mesmos arquivos salvos em GIF e PNG8

GIF·128·Selective
805 x 548 @ 72 DPI
43,2KB
Tempo @ 1mb/s: 1 segundo

PNG·128·Selective
805 x 548 @ 72 DPI
41,1KB
Tempo @ 1mb/s: 1 segundo

GIF·64·Selective
805 x 548 @ 72 DPI
33 KB 
Tempo @ 1mb/s: 0.8 segundos

PNG·64·Selective
805 x 548 @ 72 DPI
31,5 KB 
Tempo @ 1mb/s: 0.8 segundos

GIF·32·Selective·Locked 
colors>File Optimizer
805 x 547 @ 72 DPI
24 KB
Tempo @ 1mb/s: 0.6 segundos

PNG·32·Selective·Locked 
colors>File Optimizer
805 x 547 @ 72 DPI
22 KB
Tempo @ 1mb/s: 0.5 segundos

GIF·32·Selective·Locked 
colors>File Optimizer
805 x 547 @ 72 DPI
21,9 KB
Tempo @ 1mb/s: 0.5 segundos

PNG·32·Selective·Locked 
colors>File Optimizer
805 x 547 @ 72 DPI
17,2 KB
Tempo @ 1mb/s: 0.4 segundos

GIF



Pequeno manual de otimização de imagens para web · Danilo Pegorara · Design gráfico 11

Sobre

WTH 
Esse pequeno guia foi montado como um material de consulta 
para dirimir dúvidas simples na escolha do melhor tipo de com-
pressão para saída de imagens para web. Com a produção de web 
cada vez mais orientada para desempenho, e a frequência cada 
vez maior de materiais para download, é fundamental otimizar ao 
máximo o conteúdo gráfico ao mesmo tempo em que passamos a 
dispor cada vez mais desse tipo de conteúdo.

O uso de imagens não otimizadas na web acarreta problemas além 
da lentidão no carregamento. Entregar imagens “pesadas” significa 
consumir banda do usuário que, além de cara, poderia ser usada 
em outra aplicação. Isso é ainda mais problemático na navegação 
mobile, que, de modo geral, é pobre em confiabilidade e disponi-
bilidade.

Existem duas frentes técnicas na otimização de imagens para web. 
Uma delas é o designer/editor e a outra o desenvolvedor. O desen-
volvedor é responsável por implementar soluções de software que 
permitam servir conteúdo usando menos banda e fazendo menos 
requisições. Isso não significa que o material final deva ser produ-
zido sem levar a performance em consideração, uma vez que cada 
imagem é única. O processo de teste e validação do nível de oti-
mização versus qualidade depende de experiência e não pode ser 
100% automatizado.

É importante:
– Usar o menu de Save for web da suíte Adobe ou recurso similar 
de outro software;
– Selecionar o tipo correto de arquivo para apresentação do con-
teúdo (vetor, bitmap complexo, bitmap chapado);
– Editar  a imagem procurando manter o máximo de integridade 
com o mínimo de tamanho;
– Incluir o desenvolvedor nas conversas sobre soluções calcadas no 
uso massivo de imagens;
– Usar software de compressão externa quando possível.

O que não fazer:
– Usar menu de salvamento padrão do software de edição. Da mes-
ma forma que não se deve usar o menu de salvamento para web 
em materiais que serão impressos, o inverso também é verdadeiro. 
O salvamento padrão procura manter a integridade do arquivo ao 
máximo, e todos os metadados, o que é exatamente o oposto da 
lógica de imagens para web. A lógica deve ser: máximo de integri-
dade com o mínimo de tamanho;
– Trabalhar sob o preceito de que recursos de hardware são ilimita-
dos. É uma prática ruim, que desencoraja a busca de soluções óti-
mas e impede a construção de conhecimento que pode ser chave 
em situações críticas. Além disso, encarece o trabalho, forçando 
gastos desnecessário em infra.
– Ignorar os recursos do usuário. É sensato pressupor que é o site  
que deve se adequar ao hardware do internauta, e não o contrário.

Softwares externos
Os softwares externos de compressão conseguem resultados ainda 
melhores do que as saídas padrão das suítes de edição. A mecâ-
nica desses programas é variada, mas grosso modo, todos limpam 
os metadados das imagens e usam filtros que reduzem o bit depth 
sem perda visível de qualidade.

Apesar da escolha ser uma questão de teste e de preferência, é 
recomendado usar um compressor externo como o File optimizer. 
Essa ferramenta, que é a mostrada nos fluxos do guia, funciona 
como uma interface gráfica para mais de 90 engines de compres-
são, que funcionam em cadeia.

A ferramenta é open source, e gera backups dos arquivos que fo-
ram otimizados. A otimização de PNG pode ser lenta, mas normal-
mente compensa. É uma etapa a mais ao trabalho, mas que gera 
resultados sólidos (comparar tempos de carga das imagens nos 
fluxos de trabalho).
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